CVE-2020-7121 & CVE-2020-7122 Aruba CX switches firmware – Memory Corruption Kwetsbaarheid

Berry RijnbeekNieuws

Aruba Networks heeft bekend gemaakt dat er meerder kwetsbaarheden in de Aruba CX Switches firmware zijn gevonden. De kwetsbaarheden betreffen vier (4) geheugen corrupties, welke succesvol kunnen worden toegepast. De kwetsbaarheden resulteren in Local Denial of Service van Link Layer Discovery Protocol (LLDP) en Cisco Discovery Protocol (CDP) processen op de betreffende switches.

Firmware versies

De volgende Aruba Network CX switches zijn kwetsbaar met de hieronder vermelde firmware versies:

  • 8400 Series
  • 8325 Series
  • 8320 Series
  • 6400 Series
  • 6300 Series
  • 6200 Series

Versie 10.04.3030 en lager voor CVE-2020-7121
Versie 10.04.1000 en lager voor CVE-2020-7122

Advies

Aruba heeft voor de betreffende kwetsbaarheden een firmware-update uitgebracht. Het is aanbevolen om de switches te voorzien van de firmware versie waarin de kwetsbaarheden zijn verholpen.
Oplossing: De CX  switches  upgraden naar versie 10.04.3031, 10.05.0001 en hoger.
Beschikbaarheid patch: Firmware versie 10.04.3031 wordt van 13 november 2020 verwacht.
Workaround: Als het updaten van de firmware niet mogelijk is dan kan waar mogelijk het LLDP en of CDP proces worden uitgeschakeld.

Mocht u hiervoor ondersteuning willen, neem dan contact op met de PQR servicedesk 030 662 9729 / info@pqr.nl of Aruba support.

Geplaatst door
Berry Rijnbeek

Berry Rijnbeek

Lead consultant security competence team, Security Officer